Planned Works - NBNCo - Bendigo South Tower
Incident Report for Bendigo Telco
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 08:13 AEST
Investigating
Please be aware that NBNCo are completing works to upgrade the Bendigo South Fixed Wireless tower this week. Customers connected to this tower may experience a series of service interruptions on the 24th, 26th and 27th of June. Customers may experience two interruptions of up to 12 hours during this time.
Posted Jun 24, 2024 - 10:49 AEST
This incident affected: Data & Internet.