Significant Local Outage - Mobile - Regional Outage in Latrobe Valley, VIC (CS1818908)

Incident Report for Bendigo Telco

Resolved

We have been advised that the outage impacting mobile customers in Latrobe Valley VIC, has been resolved and all services should now be back to normal. If your service is still not working, please contact us on 1300 228 123.

Thank you for your patience.
Posted Aug 21, 2025 - 14:53 AEST

Investigating

We are aware of an outage impacting services to customers in Latrobe Valley, VIC. The outage is impacting Mobile Voice and Mobile Data.

We are working with our Third-Party Provider, monitoring the situation closely and will provide further updates as they become available.
Posted Aug 21, 2025 - 14:32 AEST
This incident affected: Mobile.