I66570 - Issues with Telstra Service

Incident Report for Bendigo Telco

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 14:41 AEST

Update

BT Telstra services have restored, with Telstra advising 90% of services now back online.
BT will continue to monitor services for further outages
Posted Jul 08, 2026 - 11:01 AEST

Investigating

BT are aware of issues with some Telstra services, impacting voice and data services.
BT are instigating and provide updates as soon as available.
Posted Jul 08, 2026 - 08:55 AEST
This incident affected: Data & Internet, Mobile, and Voice.