Optus has now restored mobile services impacted by the recent weather event in NSW.
If you experience any further connectivity issues, please call our team on 1300 228 123.
Posted Jul 03, 2025 - 16:29 AEST
Identified
Optus has now restored the majority of our mobile sites impacted by the weather event in NSW.
Remaining sites to be restored have lost connection due to power failures on the NSW Central and South Coast, Newcastle and New England, which is impacting mobile services for some customers.
Optus has restored many sites across the impacted regions in the Hunter Valley and mobilised all available generators to the most strategically significant sites that remain impacted, so they can be restored quickly. Optus have prioritised restoration as soon as it is safe to do so.
A reminder that emergency calls to Triple Zero on mobile networks during power outages should work if another carrier is available.
Thank you for your patience. We will provide further information as it becomes available.
Posted Jul 03, 2025 - 11:50 AEST
Investigating
Severe weather and significant flooding in Central Coast, Hunter Valley, Illawarra, and Metropolitan Sydney NSW are currently causing power outages, affecting some Mobile services.
If customers are in an impacted area, they may experience disruptions to their Optus service, including calls, text, and internet access. In the instance of an emergency, customers should still dial Triple Zero. Calls to Triple Zero on mobile networks during power outages should work if another carrier is available. We appreciate how important connectivity is for these communities and the Optus network team are taking precautionary measures in these areas including genset deployment, if feasible.