Teams Calling Issue - Outbound calls to mobiles failing

Incident Report for Bendigo Telco

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 12:15 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 09:51 AEDT

Investigating

We are investigating an issue where outbound calls are failing to mobile numbers when dialed from Teams Calling. This has been escalated to our provider, and we will provide updates they come to hand.
Posted Mar 25, 2025 - 09:48 AEDT
This incident affected: Voice.