Mobile Network Outage (CS1803812) is Open

Incident Report for Bendigo Telco

Resolved

Our supplier, Optus, has advised that this outage has now been resolved and impacted services should now be working as normal. If you are still experiencing any issues, please contact us on 1300 228 123, or customerhelp@bendigotelco.com.au. Thank you
Posted Jul 18, 2025 - 10:54 AEST

Investigating

We are aware of an outage currently impacting mobile services to customers in Horsham, VIC, due to a transmission issued. This may impact customers within the postcodes of 3388, 3390, 3392, 3400, 3401, 3475, 3477, 3478, 3480.

Our supplier, Optus, has teams working to restore all impacted services as soon as possible, and we apologise for any inconvenience caused.

We will provide more information as it becomes available. Thank you.
Posted Jul 18, 2025 - 10:42 AEST
This incident affected: Mobile.