Significant Local Outage (CS1798406)

Incident Report for Bendigo Telco

Resolved

Optus have advised that the outage impacting mobile customers in Kangaroo Flat has been resolved.
If you have any further issues, please contact us 1300 228 123.
Posted Jul 07, 2025 - 12:49 AEST

Monitoring

We are aware of an ongoing issue affecting services in Kangaroo Flat, VIC, due to an unplanned power outage.

Optus has confirmed that the site is now up and stable, and they are continuing to monitor to ensure continued stability.
Posted Jul 07, 2025 - 08:07 AEST
This incident affected: Mobile.