Optus Network Outage Due To Tropical Cyclone Alfred - QLD, NSW

Incident Report for Bendigo Telco

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 13:06 AEDT

Identified

Extreme weather conditions caused by Cyclone Alfred are currently impacting mobile services to customers in south-east Queensland and northern NSW.

Optus have 178 mobile sites that have lost connection due to power outages in southeast Queensland and northern NSW.

The safety of our customers and employees are of the utmost importance as we work as quickly as possible to restore services.

Optus continues to work with our field operations teams on the ground as Cyclone Alfred approaches the mainland.
Posted Mar 08, 2025 - 08:39 AEDT
This incident affected: Mobile.