Significant Local Outage - Mobile - Regional Outage in Murray River, Swan Hill, VIC (CS1824011)

Incident Report for Bendigo Telco

Resolved

We have been advised by our third party carrier, Optus, that this outage has now been resolved and impacted services should now be operating as normal.
If you are still experiencing issues with service, please contact us on 1300 228 123. Thank you.
Posted Sep 02, 2025 - 16:59 AEST

Investigating

We are currently investigating an outage in Murray River, Swan Hill VIC, impacting mobile services. We will provide updates as soon as they become available from the carrier.
We apologise for any inconvenience this may cause.
Posted Sep 02, 2025 - 12:56 AEST
This incident affected: Mobile.